• All errors in one place

    Quickly get to the core of any issues and resolve them efficiently.

    See all features
  • Intelligent error grouping

    Easily identify highest priority issues affecting your customers.

    See all features
  • World-class security

    Keeping your data safe is of paramount importance to us.

    See security features

Live crash data for all your apps

Raygun keeps a watchful eye on your web and mobile applications and tells you when problems arise. Add Raygun to your code in minutes and you’ll be able to detect every error in your software, the second they happen.


Integrates with your tools

Raygun has support for integrations including team chat (Slack, Hipchat etc), project management tools (JIRA, Sprintly etc) and issue trackers (Github, Bitbucket etc). The tools you already use work with Raygun.


Drop Raygun into your app in seconds

A few lines of code is all it takes to get Java exception notifications. How fast can you copy and paste?

<dependencies>
    ...
    <dependency>
        <groupId>com.mindscapehq</groupId>
        <artifactId>raygun4java</artifactId>
        <type>pom</type>
        <version>1.3.2</version>
    </dependency>
    <dependency>
        <groupId>com.mindscapehq</groupId>
        <artifactId>core</artifactId>
        <version>1.3.2</version>
    </dependency>
</dependencies>
public class MyApp
{
    public static void main(String[] args) throws Throwable
    {
            Thread.setDefaultUncaughtExceptionHandler(new MyExceptionHandler());
    }
}

class MyExceptionHandler implements Thread.UncaughtExceptionHandler
{
    @Override
    public void uncaughtException(Thread t, Throwable e) {
        RaygunClient client = new RaygunClient("YOUR_APP_API_KEY");
        client.Send(e);

    }
}

Get up and running in minutes

Nothing to download, nothing to install, just one simple, short code snippet is all you need to catch errors in production and get deep and meaningful insights into your applications.

Try it free for 14 days

No credit card required